Odd error reports relating to initialization of mDash in the arduino IDE

#1

Howdy,
I’ve been trying to start using mDash on My generic ESP32 dev board. But, I’m get some error messages I haven’t seen anywhere else on the forum when trying to flash an unaltered version of the Minimal sketch. The full non-verbose error log is:


Library mDash has been declared precompiled:
Using precompiled library in C:\Users\Hue Mungus\Documents\Arduino\libraries\mDash\src\esp32
The plaform does not support ‘compiler.libraries.ldflags’ for precompiled libraries.
sketch\Minimal.ino.cpp.o:(.literal._Z5setupv+0x28): undefined reference to mDashInit' sketch\Minimal.ino.cpp.o: In functionsetup()’:
C:\Users\HUEMUN~1\AppData\Local\Temp\arduino_modified_sketch_329437/Minimal.ino:26: undefined reference to `mDashInit’
collect2.exe: error: ld returned 1 exit status
Multiple libraries were found for “WiFi.h”
Used: C:\Users\Hue Mungus\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.0\libraries\WiFi
Not used: C:\Program Files (x86)\Arduino\libraries\WiFi
exit status 1
Error compiling for board ESP32 Dev Module.


I’ve successfully flashed firmware with the same config, but different sketch, and in such verified my board is working. The config is everything as listed up at the top of the minimal sketch. I poked around the forums, and figured I should use the 1.0.0 core for the esp32- though I tried all the rest of them on the newest release of mDash. I also went back to previous revisions of mDash, using the 1.0.0 core, but had no luck. final note, though I don’t know how important it is, is I’m using the arduino IDE rev 1.8.13.

#2

The version of Arduino IDE seems to be important.
1.8.12 and 1.8.13 throw errors, 1.8.9, 1.8.10 and 1.8.11 don’t.
Tested with Arduino esp32 1.0.4 and mDash 1.2.13.

1 Like
#3

It worked! thank you so much!