Can't connect ESP8266 to mdash.net

#1

Log:

rBoot v1.2.1-cesanta1 - richardaburton@gmail.com
[Mar 11 18:12:12.680] Flash Size:   32 Mbit
[Mar 11 18:12:12.682] Flash Mode:   DIO
[Mar 11 18:12:12.685] Flash Speed:  80 MHz
[Mar 11 18:12:12.685] rBoot Option: Big flash
[Mar 11 18:12:12.689] 
[Mar 11 18:12:12.727] Booting rom 0 (0x100000).
[Mar 11 18:12:12.784]     e o  ;  g|  l ld$`  # e   | {  $ n   o   $`   s l le mode : s
[Mar 11 18:12:12.791] esp_main.c:172          app1 1.0 (20200311-101343)
[Mar 11 18:12:12.794] esp_main.c:174          Mongoose OS 2.17.0 (20200311-101343/2.17.0-gc31a745)
[Mar 11 18:12:12.802] esp_main.c:178          CPU: ESP8266EX, 160 MHz, RAM: 51592 total, 49396 free
[Mar 11 18:12:12.808] esp_main.c:180          SDK 2.2.1(1247cc5); flash: 4M
[Mar 11 18:12:12.813] esp_exc.c:211           Reset cause: 6 (sys reset)
[Mar 11 18:12:12.816] mg_lwip_ev_mgr.c:77     Mongoose 6.16, LwIP 1.4.1
[Mar 11 18:12:12.822] mg_ssl_if_mbedtls.c:57  mbed TLS 2.16.3-cesanta9
[Mar 11 18:12:12.825] mgos_vfs_dev.c:73       sfl0: sysflash (), size 4194304
[Mar 11 18:12:12.832] mgos_vfs_dev.c:73       root: part ({"dev": "sfl0", "offset": 32768, "size": 262144}), size 262144
[Mar 11 18:12:12.840] mgos_vfs.c:174          /: SPIFFS @ root, opts {"bs":4096,"ps":256,"es":4096}
[Mar 11 18:12:12.907] mgos_vfs.c:347          /: size 233681, used: 137799, free: 95882
[Mar 11 18:12:13.023] mgos_sys_config.c:232   Loading conf9.json
[Mar 11 18:12:13.035] mgos_sys_config.c:366   MAC: 3a:2b:78:03:d5:6e
[Mar 11 18:12:13.041] mgos_sys_config.c:374   WDT: 30 seconds
[Mar 11 18:12:13.045] mgos_i2c_gpio_maste:250 I2C GPIO init ok (SDA: 12, SCL: 14, freq: 100000)
[Mar 11 18:12:13.057] mgos_ota_shadow_lib:116 OTA over shadow initialised
[Mar 11 18:12:13.058] del if0
[Mar 11 18:12:13.058] usl
[Mar 11 18:12:13.061] mode : null
[Mar 11 18:12:13.061] mgos_wifi.c:458         WiFi mode: AP
[Mar 11 18:12:13.064] esp_wifi.c:108          WiFi mode: AP
[Mar 11 18:12:13.066] mode : softAP(3a:2b:78:03:d5:6e)
[Mar 11 18:12:13.069] add if1
[Mar 11 18:12:13.072] dhcp server start:(ip:192.168.4.1,mask:255.255.255.0,gw:192.168.4.1)
[Mar 11 18:12:13.078] bcn 100
[Mar 11 18:12:13.078] esp_wifi.c:307          WiFi AP: SSID Mongoose_03D56E, channel 6
[Mar 11 18:12:13.966] bcn 0
[Mar 11 18:12:13.966] del if1
[Mar 11 18:12:13.966] usl
[Mar 11 18:12:13.966] add if1
[Mar 11 18:12:13.966] dhcp server start:(ip:192.168.4.1,mask:255.255.255.0,gw:192.168.4.1)
[Mar 11 18:12:13.975] bcn 100
[Mar 11 18:12:13.975] esp_wifi.c:355          WiFi AP IP: 192.168.4.1/255.255.255.0 gw 192.168.4.1, DHCP range 192.168.4.2 - 192.168.4.100
[Mar 11 18:12:13.983] mgos_http_server.c:343  HTTP server started on [80]
[Mar 11 18:12:13.992] mgos_dash.c:203         Dash init ok, server: wss://mdash.net/api/v2/rpc)
[Mar 11 18:12:13.999] mgos_provision_btn.c:75 Factory reset button: pin 0, pull up, hold_ms 0 (hold on boot)
[Mar 11 18:12:14.018] mgos_provision_stat:119 Max state: 0
[Mar 11 18:12:14.021] mgos_rpc_channel_mq:203 0x3fff1684 device1/rpc
[Mar 11 18:12:14.029] mgos_rpc_channel_ua:313 0x3fff1c5c UART0
[Mar 11 18:12:14.034] mgos_init.c:36          Init done, RAM: 51592 total, 40312 free, 40320 min free
[Mar 11 18:12:14.804] LED on -> false 
[Mar 11 18:12:14.892] mgos_mongoose.c:66      New heap free LWM: 25856
[Mar 11 18:12:14.896] mgos_ota_core.c:1318    UID: 03a0b6845f80f412, license: none
[Mar 11 18:12:15.832] online: false {"ram_free":31384,"uptime":3.120693,"btnCount":0,"on":false} 
[Mar 11 18:12:16.831] online: false {"ram_free":31360,"uptime":4.120293,"btnCount":0,"on":false} 
[Mar 11 18:12:17.831] online: false {"ram_free":31360,"uptime":5.120308,"btnCount":0,"on":false} 
[Mar 11 18:12:18.831] online: false {"ram_free":31360,"uptime":6.120240,"btnCount":0,"on":false} 
[Mar 11 18:12:19.831] online: false {"ram_free":31360,"uptime":7.120205,"btnCount":0,"on":false}
#2

You need to connect the device to a WiFi access point in order to have internet access.

mos wifi SSID PASSWORD