Device lose connection with mDash

Hi guys!
I’m a newbie programmer working on a project using esp32 that reads some data like temperature, current and voltage. This data is sent to an MQTT broker. The problem i’m facing is the following: When i first uploaded my firmware a few months, everything worked pretty well. But when i updated the firmware via mDash the device lose its connection. MQTT keeps receiving data but mDash never reconects, even if i reboot the device. I tried to use older versions but it worked the same way. What could it be? A problem in the network i’m using or something like that?

thanks in advance

It’s hard to tell if you are saying that the connection drops occasionally, or if you are saying that after FW update the device does not connect at all.

Few things to check:

  1. When updated the FW are you sure you didn’t remove the mdash configuration somehow? Default behaviour of OTA update is to preserve the configuration, but I you haven’t shared any code.
  2. Check the console messages you should see the exact reason for connect/disconnect

Since you say you’re a newbie I would start with number 2 - it’s easiest to just plug the device in via USB if you can.

If you’ve got your device somewhere thats hard to access but has network connectivity you can still get console logs, but will require some more stuffing around

Yes - observing the serial terminal is a very useful debugging tool.