Progressive web app not appearing: Mongoose, mDash, smart light on Mongoose OS

#1

Hello,
As a primary stage of learning, I have attempted this tutorial: Full IoT product: smart light on Mongoose OS. Till step 7 everything worked according to the video tutorial. On step 8 I tried to open the progressive web app but it is not opening. I am not sure what is causing the problem but I suspect that I am not using the right IP address on the phone while opening the progressive web app.

For example, my computer has an IP address: zzz.xxx.ccc.vvv. So when I was programming the device (step 6,7) I have used that IP address as “YOUR_WORKSTATION_IP”. In step 8 (Me as a customer), it is mentioned to add “YOUR_WORKSTATION_IP:8008” to the browser of my mobile. Please correct me if I am wrong, as I customer I do not have the access to the IP address: zzz.xxx.ccc.vvv. But for example, As a customer My mobile phone’s IP address is aaa.sss.ddd.fff. So, do I use this aaa.sss.ddd.fff:8008 to the browser of my phone or should I try zzz.xxx.ccc.vvv:8008? I tried both but it is not working.

I am not sure whether this information is necessary or not but My PC is connected to the internet through LAN and My mobile is connected to the internet through WiFi and I am using ESP32.

And also If I open up the ESP32 IP address on the browser it shows me 3 files ca.pem, conf5.json, conf0.json. And the conf0.json file is empty. It only has an empty open and close-ended curly braces {}.

I would really appreciate it if someone can help me understand and eventually solve this issue.

Thank you.
Ifthekhar