The certificate common name (cn) does not match with the expected cn

#1

Hello,

when I want to register my ESP8266 to mDash I get this error. Is it because mDash is only for ESP32 and not other devices?

TY.

#2

Mongoose OS devices work with mDash regardless of the architecture.
Please share exactly the config you’re using and the returned error.

#3


This is my output. I didn’t change anything in configuration since I just started.

#4

Please try

mos config-set dash.server=wss://mdash.net/api/v2/rpc
#5

Same thing happens. Do I need to change certificate?

#6

The stock ca-bundle library (which delivers ca.pem file) should work fine .
Do you use an unmodified ca.pem ?

#7

Since this device was used before, someone could have modified ca.pem, however since I am new to this stuff, I don’t know how to check it. Can you please tell me how?

#8
  1. Make a backup of existing ca.pem mos get ca.pem > backup.ca.pem
  2. Download the stock one, curl -O https://raw.githubusercontent.com/mongoose-os-libs/ca-bundle/master/fs/ca.pem
  3. Upload to the device mos put ca.pem
  4. Reboot the device mos call Sys.Reboot
#9

Doesn’t work. I guess ca.pem was left untouched. I still get the same error.

#10

Does your browser show the warning when you visit https://mdash.net ?

#11

Not at work ATM, but nope, didn’t show any warnings.

#12

Can’t reproduce. Works fine on our side:

$ mos --port /dev/cu.wchusbserial1420 config-get dash
{
  "enable": true,
  "send_logs": false,
  "server": "wss://dash.mongoose-os.com/api/v2/rpc",
  "ssl_ca_cert": "ca.pem",
  "ssl_cert": "",
  "ssl_key": "",
  "token": "...."
}

It connects to the mdash.net with no issues.
Please try on a vanilla new ESP8266 box to verify.